Inter-VLAN Routing Configuration

by Jim Johnston

R1

R1#sh run

Building configuration...

Current configuration : 909 bytes

!

version 12.4

service password-encryption

!

hostname R1

!

!

enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1

!

!

!

!

ip ssh version 1

!

!

interface FastEthernet0/0

description WEB/TFTP Server Link

ip address 172.17.50.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.10

encapsulation dot1Q 10

ip address 172.17.10.1 255.255.255.0

!

interface FastEthernet0/1.20

encapsulation dot1Q 20

ip address 172.17.20.1 255.255.255.0

!

interface FastEthernet0/1.30

encapsulation dot1Q 30

ip address 172.17.30.1 255.255.255.0

!

interface FastEthernet0/1.99

encapsulation dot1Q 99 native

ip address 172.17.99.1 255.255.255.0

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

!

!

!

!

banner motd ^CAuthorized Access Only^C

line con 0

password 7 0822455D0A16

login

line vty 0 4

password 7 0822455D0A16

login

!

!

end

S1

S1#sh run

Building configuration...

Current configuration : 1460 bytes

!

version 12.1

service password-encryption

!

hostname S1

!

enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1

!

no ip domain-lookup

!

spanning-tree vlan 10,20,30,99 priority 4096

!

interface FastEthernet0/1

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/2

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/3

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/4

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/5

switchport trunk native vlan 99

switchport mode trunk

!

<Disabled interfaces are not shown>

!

interface Vlan1

no ip address

shutdown

!

interface Vlan99

ip address 172.17.99.31 255.255.255.0

!

ip default-gateway 172.17.99.1

!

banner motd ^CAuthorized Access Only^C

line con 0

password 7 0822455D0A16

login

!

line vty 0 4

password 7 0822455D0A16

login

line vty 5 15

password 7 0822455D0A16

login

!

!

end

S2

S2#sh run

Building configuration...

Current configuration : 1512 bytes

!

version 12.1

service password-encryption

!

hostname S2

!

enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1

!

no ip domain-lookup

!

!

interface FastEthernet0/1

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/2

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/3

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/4

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/5

!

interface FastEthernet0/6

switchport access vlan 30

switchport mode access

!

<Disabled interfaces are not shown>

!

interface FastEthernet0/11

switchport access vlan 10

switchport mode access

!

<Disabled interfaces are not shown>

!

interface FastEthernet0/18

switchport access vlan 20

switchport mode access

!

<Disabled interfaces are not shown>

!

interface Vlan1

no ip address

shutdown

!

interface Vlan99

ip address 172.17.99.32 255.255.255.0

!

ip default-gateway 172.17.99.1

!

banner motd ^CAuthorized Access Only^C

line con 0

password 7 0822455D0A16

login

!

line vty 0 4

password 7 0822455D0A16

login

line vty 5 15

password 7 0822455D0A16

login

!

!

end

S3

S3#sh run

Building configuration...

Current configuration : 1410 bytes

!

version 12.1

service password-encryption

!

hostname S3

!

enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1

!

no ip domain-lookup

!

!

interface FastEthernet0/1

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/2

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/3

switchport trunk native vlan 99

switchport mode trunk

!

interface FastEthernet0/4

switchport trunk native vlan 99

switchport mode trunk

!

<Disabled interfaces are not shown>

!

interface FastEthernet0/11

switchport access vlan 99

switchport mode access

!

<Disabled interfaces are not shown>

!

interface Vlan1

no ip address

shutdown

!

interface Vlan99

ip address 172.17.99.33 255.255.255.0

!

ip default-gateway 172.17.99.1

!

banner motd ^CAuthorized Access Only^C

line con 0

password 7 0822455D0A16

login

!

line vty 0 4

password 7 0822455D0A16

login

line vty 5 15

password 7 0822455D0A16

login

!

!

end