Title:Configuration Example – Juniper Cisco Alcatel 6PE interoperability
Juniper Cisco Alcatel 6PE interoperability
Product: M320
Version: 10.0R2
Network Topology:
Description
Juniper’s M320, Cisco’s GSR and Alcatel’s 7750SR are in the same network to provide 6PE service, Juniper router is used as router reflector, respective configuration and different behaviour is to be discussed.
Configuration:
### Juniper M320 PE1 configuration
### BGP to RR
[edit protocols bgp]
test@pe1# show group 6pe-backbone
type internal;
neighbor 172.25.212.8 {
local-address 172.25.146.40;
family inet6 {
labeled-unicast {
explicit-null;
}
}
}
### BGP to external peer
test@pe1# show group 6pe-peer
type external;
family inet6 {
unicast;
}
neighbor fc00:300:2::2 {
peer-as 65001;
}
### enable ipv6 on loopback
test@pe1# show interfaces lo0
unit 0 {
family inet {
no-redirects;
address 172.25.146.40/32;
}
family iso {
address 49.0403.1720.2514.6040.00;
}
family inet6 {
address fc00:300:1::1/128;
}
}
### enable ipv6 on backbone link
test@pe1# show interfaces ge-1/1/9
description "to BR1 2/0 ";
unit 0 {
family inet {
address 192.168.30.2/24;
}
family iso;
family inet6;
family mpls;
}
### turn on mpls tunnelling
test@pe1# show protocols mpls
ipv6-tunneling;
### Cisco GSR PE2 configuration
ip cef
!
ipv6 cef
!
ipv6 unicast-routing
mpls ipv6 source-interface Loopback0
!
interface Loopback0
ip address 172.73.73.73 255.255.255.255
ip pim sparse-mode
ipv6 address FC00:400:1::1/128
!
interface GigabitEthernet0/1.125
encapsulation dot1Q 125
ipv6 address fc00:400:4::2/80
!
router bgp 65400
no synchronization
no bgp default ipv4-unicast
neighbor 172.25.212.8 remote-as 65400
neighbor 172.25.212.8 update-source Loopback0
neighbor fc00:400:4::1 remote-as 65002
!
address-family ipv6
neighbor 172.25.212.8 activate
neighbor 172.25.212.8 send-label
neighbor fc00:400:4::1 activate
exit-address-family
!
### Alcatel 7750SR PE3 configuration
### BGP to RR
*A:PE3>config>router>bgp# info
------
group "mvpn"
family ipv4 ipv6
hold-time 45
keepalive 15
min-route-advertisement 1
local-as 65400
peer-as 65400
local-address 172.25.212.23
enable-peer-tracking
neighbor 172.25.212.8
family ipv4 ipv6 vpn-ipv4 vpn-ipv6 mvpn-ipv4
advertise-label ipv6
exit
exit
### BGP to external peer
*A:PE3>config>router>bgp# info
------
group "6pe-peer"
family ipv6
hold-time 45
keepalive 15
min-route-advertisement 1
neighbor fc00:400:4::2
family ipv6
peer-as 65003
exit
exit
### IES services
*A:PE3>config>service>ies# info
------
interface "to-7301" create
ipv6
address fc00:400:4::1/80
exit
sap 1/1/3:125 create
exit
exit
no shutdown
------
### Global system ipv6
*A:PE3>config>router# interface "system"
*A:PE3>config>router>if# info
------
address 172.25.212.23/32
ipv6
address fc00:400:1::2/128
exit
------
Verification:
By checking IPv6 routes on each PE,you can observe IPv6 works between Cisco Juniper and Alcatel box correctly.
Conclusion 1 –
Next-hop automatically changed to ::ffff:loopback when advertise routes to RR; change to local ipv6 interface address when advertise routes to local ipv6 peers.
test@pe1# run show route advertising-protocol bgp 172.25.212.8 extensive
inet6.0: 134 destinations, 150 routes (133 active, 0 holddown, 2 hidden)
* fc00:300:3::1/128 (1 entry, 1 announced)
BGP group 6pe-backbone type Internal
Route Label: 2
Nexthop: Self
Flags: Nexthop Change
Localpref: 100
AS path: 65001 I
test@pe1# run show route advertising-protocol bgp fc00:300:2::2 extensive
inet6.0: 134 destinations, 150 routes (133 active, 0 holddown, 2 hidden)
* fc00:400:7::1/128 (2 entries, 1 announced)
BGP group 6pe-peer type External
Nexthop: Self
AS path: 65400 65002 I
Conclusion 2 –
Juniper M320 create inet6.3 table derived from local inet.3 table, which is not the case on Cisco and Alcatel platform.
test@pe1# run show route table inet6.3
inet6.3: 347 destinations, 347 routes (347 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
::ffff:8.8.8.0/120 *[LDP/9] 2d 23:49:51, metric 25030
> to 10.80.1.2 via ge-5/1/1.0, Push 772
test@pe1 # run show route table inet.3
inet.3: 354 destinations, 354 routes (354 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
0.0.0.0/0 *[Static/5] 3w3d 22:21:56
> to 172.18.132.1 via fxp0.0
8.8.8.0/24 *[LDP/9] 2d 23:50:00, metric 25030
> to 10.80.1.2 via ge-5/1/1.0, Push 772
Conclusion 3 –
Quote from RFC 4798 “The label bound by MP-BGP to the IPv6 prefix indicates to the egress 6PE Router that the packet is an IPv6 packet. This label advertised by the egress 6PE Router with MP-BGP MAY be an arbitrary label value, which identifies an IPv6 routing context or outgoing interface to send the packet to, or MAY be the IPv6 Explicit Null Label”. Juniper Alcatel and Cisco have different choice.
M320 PE1 advertise explicate-null as BGP label
* fc00:300:1::1/128 (1 entry, 1 announced)
BGP group 6pe-backbone type Internal
Route Label: 2
Nexthop: ::ffff:172.25.146.40
Flags: Nexthop Change
Localpref: 100
AS path: [65400] I
GSR PE2 advertise non explicate-null as BGP label
* fc00:400:1::1/128 (1 entry, 1 announced)
Accepted
Route Label: 1065
Nexthop: ::ffff:172.73.73.73
MED 0
Localpref: 100
AS path: I
AS path: Recorded
Alcatel PE3 advertise explicate-null as BGP label
A:PE3# show router bgp routes hunt ipv6
Network : fc00:400:6::/80
Nexthop : ::FFFF:AC19:D417
To : 172.25.212.8
Res. Nexthop : n/a
Local Pref. : 100 Interface Name : NotAvailable
Aggregator AS : None Aggregator : None
Atomic Aggr. : Not Atomic MED : 0
Community : No Community Members
Cluster : No Cluster Members
Originator Id : None Peer Router Id : 172.25.212.8
IPv4 Label : 2 (Ipv6 Explicit-Null)
Origin : IGP
AS-Path : 65400 65003
1